RubyGems Navigation menu

malloc 1.5.1

This Ruby extension defines the class Hornetseye::Malloc. Hornetseye::Malloc#new allows you to allocate memory, using Hornetseye::Malloc#+ one can do pointer manipulation, and Hornetseye::Malloc#read and Hornetseye::Malloc#write provide reading Ruby strings from memory and writing Ruby strings to memory.

Versions:

  1. 1.5.1 - May 15, 2015 (21.5 KB)
  2. 1.5.0 - May 4, 2015 (21.5 KB)
  3. 1.4.0 - December 29, 2010 (21 KB)
  4. 1.3.7 - December 12, 2010 (21 KB)
  5. 1.3.6 - November 18, 2010 (21 KB)
Show all versions (30 total)

Authors:

  • Jan Wedekind

Owners:

6ef9aa6aad6b3a0251d6872bc4c5bdae

Sha 256 checksum:

9fdb4d4ccea6cf21fb23e3a3a51c2f8ad62ac38a605b5723a14e441ce559d607

Total downloads 45,351

For this version 213

Show all versions (30 total)

Required Ruby Version: >= 0

Licenses:

GPL-3+

Gemfile:
= Copy to clipboard Copied!

install:
= Copy to clipboard Copied!

Links: