RubyGems Navigation menu

mkmf-lite 0.6.0

The mkmf-lite library is a light version of the the mkmf library designed for use as a library. It does not create packages, builds, or log files of any kind. Instead, it provides mixin methods that you can use in FFI or tests to check for the presence of header files, constants, and so on.

Gemfile:
= Copy to clipboard Copied!

install:
=

Versions:

  1. 0.6.0 - September 26, 2023 (20.5 KB)
  2. 0.5.2 - March 24, 2023 (20 KB)
  3. 0.5.1 - December 18, 2020 (20 KB)
  4. 0.5.0 - December 06, 2020 (20 KB)
  5. 0.4.2 - August 31, 2020 (19.5 KB)
Show all versions (18 total)

Runtime Dependencies (2):

memoist ~> 0.16.2
ptools ~> 1.4

Development Dependencies (4):

rake >= 0
rspec ~> 3.9
rubocop >= 0

Owners:

Pushed by:

Authors:

  • Daniel J. Berger

SHA 256 checksum:

af46e83809a1dc6cd1ad776ecd81ffccf20c3903d642b0297e6a73d3919cdea7

Signature validity period:

March 18, 2018 - March 15, 2028

Total downloads 41,565

For this version 760

License:

Apache-2.0

Required Ruby Version: >= 0

New versions require MFA: true

Version published with MFA: true

Links: