RubyGems Navigation menu

pact 1.59.0

Enables consumer driven contract testing, providing a mock service and DSL for the consumer project, and interaction playback and verification for the service provider project.

Versions:

  1. 1.59.0 - September 07, 2021 (59 KB)
  2. 1.58.0 - September 07, 2021 (59 KB)
  3. 1.57.0 - January 31, 2021 (58.5 KB)
  4. 1.56.0 - January 21, 2021 (58.5 KB)
  5. 1.55.7 - November 25, 2020 (58.5 KB)
Show all versions (150 total)

Runtime Dependencies (7):

  • pact-mock_service ~> 3.0, >= 3.3.1
  • pact-support ~> 1.15
  • rack-test >= 0.6.3, < 2.0.0
  • rspec ~> 3.0
  • term-ansicolor ~> 1.0
  • thor >= 0.20, < 2.0
  • webrick ~> 1.3
  • Development Dependencies (10):

    Owners:

    Pushed by:

    Authors:

    • James Fraser, Sergei Matheson, Brent Snook, Ronald Holshausen, Beth Skurrie

    SHA 256 checksum:

    6272cea35e4ee809493fadcba9800d4a24c262ef0778a0d1ba5d9a9b3f61fc59

    Total downloads 4,588,129

    For this version 93,050

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    MIT

    Required Ruby Version: >= 2.0

    Links: