RubyGems Navigation menu

pry-debugger-jruby 2.0.0-java

Add a JRuby-compatible debugger to 'pry'. Adds 'step', 'next', 'continue', `break` and `breakpoints` commands to control execution.

Versions:

  1. 2.0.0 - November 11, 2020 java (14 KB)
  2. 1.2.2 - August 18, 2020 java (14 KB)
  3. 1.2.1 - June 06, 2018 java (13.5 KB)
  4. 1.2.0 - December 03, 2017 java (13.5 KB)
  5. 1.1.0 - December 02, 2016 java (13.5 KB)
Show all versions (6 total)

Runtime Dependencies (2):

  • pry >= 0.13, < 0.14
  • ruby-debug-base >= 0.10.4, < 0.12
  • Development Dependencies (3):

  • bundler ~> 2.1
  • pry-remote ~> 0.1.6
  • rake ~> 13.0
  • Owners:

    Pushed by:

    Authors:

    • Ivo Anjo

    SHA 256 checksum:

    128cf9f1c73599574abfb9884ac2af60d9d339d317bc0f361c25145d996b4aff

    Total downloads 78,660

    For this version 568

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    MIT

    Required Ruby Version: >= 2.2.0

    Links: