RubyGems Navigation menu

require_dir 2.0.0

Easily and non-intrusively require files from sub-folders. Without polluting global namespace, or having modules clobber each other, include RequireDir and initialize it to get access to #dir and #dir_r

Versions:

  1. 2.0.0 - March 30, 2018 (18 KB)
  2. 1.0.0 - March 22, 2018 (17 KB)
  3. 0.1.2 - July 14, 2016 (16.5 KB)
  4. 0.1.1 - July 03, 2016 (7.5 KB)
  5. 0.1.0 - July 03, 2016 (7.5 KB)

Runtime Dependencies (1):

Development Dependencies (4):

  • bundler ~> 1.12
  • rake ~> 10.0
  • rspec ~> 3.0
  • simplecov >= 0
  • Owners:

    Authors:

    • Konstantin Gredeskoul

    SHA 256 checksum:

    14ac03e61753b632824b9832abc683b3eb94d5fc3f478ba07938e60052c0e4a8

    Total downloads 21,460

    For this version 14,120

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    MIT

    Required Ruby Version: >= 0

    Links: