RubyGems Navigation menu

rex-encoder 0.1.5

This library provides the basis for all of the polymorphic encoders that Metasploit uses for payload encoding. Encoders are used to try and create a version of a payload that is free of bad characters as defined by the exploit.

Versions:

  1. 0.1.5 - November 30, 2020 (40 KB)
  2. 0.1.4 - May 11, 2017 (40 KB)
  3. 0.1.3 - April 07, 2017 (40 KB)
  4. 0.1.2 - December 28, 2016 (40 KB)
  5. 0.1.1 - November 21, 2016 (39.5 KB)
Show all versions (6 total)

Runtime Dependencies (3):

Development Dependencies (2):

  • rake >= 0
  • rspec >= 0
  • Owners:

    Pushed by:

    Authors:

    • Metasploit Hackers

    SHA 256 checksum:

    e74e12a0f9bb9b562635b3b787e5e8ed0cf8db5d825c7e442a238f8662a4d952

    Total downloads 1,545,693

    For this version 201,831

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    Licenses:

    N/A

    Required Ruby Version: >= 2.2.0

    Links: