RubyGems Navigation menu

ronin-payloads 0.1.6

ronin-payloads is a Ruby micro-framework for writing and running exploit payloads. ronin-payloads allows one to write payloads as plain old Ruby classes. ronin-payloads can be distributed as Ruby files or in git repositories that can be installed with ronin-repos. It's like `msfvenom` but simpler and more modular.

Gemfile:
= Copy to clipboard Copied!

install:
=

Versions:

  1. 0.2.0.rc2 - July 03, 2024 (57 KB)
  2. 0.2.0.rc1 - June 23, 2024 (56.5 KB)
  3. 0.1.6 - July 03, 2024 (48.5 KB)
  4. 0.1.5 - June 20, 2024 (48.5 KB)
  5. 0.1.4 - September 19, 2023 (48.5 KB)
Show all versions (10 total)

Runtime Dependencies (5):

ronin-core ~> 0.1
ronin-post_ex ~> 0.1
ronin-repos ~> 0.1
ronin-support ~> 1.0

Development Dependencies (1):

bundler ~> 2.0

Owners:

Pushed by:

Authors:

  • Postmodern

SHA 256 checksum:

= Copy to clipboard Copied!

Total downloads 7,147

For this version 190

License:

LGPL-3.0

Required Ruby Version: >= 3.0.0

New versions require MFA: true

Version published with MFA: true

Links: