RubyGems Navigation menu

rusty_lru 0.1.2

This gem provides an LRU cache with an interface close to Hash. It uses Rutie to wrap the Rust 'lru' crate.

Versions:

  1. 0.1.2 - June 05, 2021 (17 KB)
  2. 0.1.1 - August 30, 2019 (16 KB)
  3. 0.1.0 - August 30, 2019 (16 KB)

Runtime Dependencies (1):

  • rutie ~> 0.0.3
  • Development Dependencies (7):

  • bundler ~> 2.0
  • irb ~> 1.3.5
  • rake >= 12.3.3
  • rspec ~> 3.0
  • rubocop ~> 1.16.0
  • rubocop-rake ~> 0.5.1
  • rubocop-rspec ~> 2.3.0
  • Owners:

    Pushed by:

    Authors:

    • Alastair Pharo

    SHA 256 checksum:

    5820a2ddaf036edd5f42a90320962acf75fa2b45c6a5a633fa852211b091c440

    Total downloads 2,838

    For this version 752

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    Apache-2.0

    Required Ruby Version: >= 2.5

    Links: