RubyGems Navigation menu

sequel_pg 1.6.18

sequel_pg overwrites the inner loop of the Sequel postgres adapter row fetching code with a C version. The C version is significantly faster (2-6x) than the pure ruby version that Sequel uses by default. sequel_pg also offers optimized versions of some dataset methods, as well as adds support for using PostgreSQL streaming.

Versions:

  1. 1.6.18 - April 27, 2017 (19 KB)
  2. 1.6.17 - April 29, 2016 (19 KB)
  3. 1.6.16 - April 11, 2016 (18.5 KB)
  4. 1.6.15 - April 11, 2016 (18.5 KB)
  5. 1.6.14 - January 19, 2016 (18.5 KB)
Show all versions (67 total)

Runtime Dependencies (2):

Authors:

  • Jeremy Evans

Owners:

F183bcc4176b308c9edabe79299e448f

SHA 256 checksum:

b4f4d8426c2f26de355ba32e53560323e71f0a56e21ea59c8e1721c99df0fe21

Total downloads 310,208

For this version 2,291

Gemfile:
= Copy to clipboard Copied!

install:
=

License:

MIT

Required Ruby Version: >= 1.8.7

Links: