RubyGems Navigation menu

sleepy_penguin 3.5.1

sleepy_penguin provides access to newer, Linux-only system calls to wait on events from traditionally non-I/O sources. Bindings to the eventfd, timerfd, inotify, and epoll interfaces are provided. Experimental support for kqueue on FreeBSD (and likely OpenBSD/NetBSD) is also provided.

Versions:

  1. 3.5.1 - December 15, 2018 (66.5 KB)
  2. 3.5.0 - March 22, 2017 (66 KB)
  3. 3.4.1 - January 11, 2015 (58 KB)
  4. 3.3.0 - December 30, 2013 (72 KB)
  5. 3.2.0 - July 16, 2013 (71.5 KB)
Show all versions (16 total)

Development Dependencies (2):

Owners:

Authors:

  • sleepy_penguin hackers

SHA 256 checksum:

811d98199762495fe0264e50746d7dba26ede4bcbcd3a533976b4c37534a7eda

Total downloads 34,795

For this version 714

Gemfile:
= Copy to clipboard Copied!

install:
=

License:

LGPL-2.1+

Required Ruby Version: >= 2.0

Links: