RubyGems Navigation menu

smart_initializer 0.9.1

A simple and convenient way to declare complex constructors

Versions:

  1. 0.9.1 - March 18, 2022 (30 KB)
  2. 0.9.0 - December 18, 2021 (29.5 KB)
  3. 0.8.0 - December 04, 2021 (29.5 KB)
  4. 0.7.0 - June 28, 2021 (25 KB)
  5. 0.6.0 - June 23, 2021 (25 KB)
Show all versions (17 total)

Runtime Dependencies (3):

Development Dependencies (6):

  • armitage-rubocop ~> 1.23
  • bundler ~> 2.2
  • pry ~> 0.14
  • rake ~> 13.0
  • rspec ~> 3.10
  • simplecov ~> 0.21
  • Owners:

    Pushed by:

    Authors:

    • Rustam Ibragimov

    SHA 256 checksum:

    99355d8790f0b8e71efc58c7926db65274ac6b132f2fd7ebe6d5ed4e120c800f

    Total downloads 65,803

    For this version 872

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    MIT

    Required Ruby Version: >= 2.5

    Links: