RubyGems Navigation menu

symphony-ssh 0.4.0

A small collection of base classes used for interacting with remote machines over ssh. With them, you can use AMQP (via Symphony) to run batch commands, execute templates as scripts, and perform any batch/remoting stuff you can think of without the need of separate client agents.

Versions:

  1. 0.4.0 - July 16, 2020 (11.5 KB)
  2. 0.3.0 - July 09, 2020 (11.5 KB)
  3. 0.2.1 - April 07, 2020 (9 KB)
  4. 0.2.0 - July 12, 2018 (10 KB)
  5. 0.1.1 - May 28, 2014 (9 KB)
Show all versions (6 total)

Runtime Dependencies (5):

  • configurability >= 3.2, <= 4.99
  • inversion ~> 1.3
  • net-sftp ~> 3.0
  • net-ssh ~> 6.0
  • symphony ~> 0.13
  • Development Dependencies (2):

  • rspec ~> 3.9
  • simplecov ~> 0.18
  • Owners:

    Pushed by:

    Authors:

    • Mahlon E. Smith, Michael Granger

    SHA 256 checksum:

    d9dc8491297590bdda30c9cf4627a52d293474f8399e701a0b4dd3cf1c6e271b

    Total downloads 5,232

    For this version 349

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    BSD-3-Clause

    Required Ruby Version: >= 2.6.0

    Links: