RubyGems Navigation menu

validating-workflow 0.7.10

Validating-Workflow is a finite-state-machine-inspired API for modeling and interacting with what we tend to refer to as 'workflow'. * nice DSL to describe your states, events and transitions * robust integration with ActiveRecord and non relational data stores * various hooks for single transitions, entering state etc. * convenient access to the workflow specification: list states, possible events for particular state * state and transition dependent validations for ActiveModel

Versions:

  1. 0.7.10 - April 25, 2018 (20.5 KB)
  2. 0.7.9 - May 24, 2017 (20.5 KB)
  3. 0.7.7 - February 27, 2014 (19.5 KB)
  4. 0.7.6 - February 27, 2014 (18.5 KB)
  5. 0.7.2 - October 15, 2010 (18 KB)
Show all versions (6 total)

Authors:

  • Vladimir Dobriakov, Willem van Kerkhof

Owners:

8258472d81b3c3138af572bb746c7dc9

SHA 256 checksum:

2907f42ea84acbbfc5c7d573d0ef30132cd0c42fedfc15c88bba52a4aa702a1c

Total downloads 5,305

For this version 189

Gemfile:
= Copy to clipboard Copied!

install:
=

License:

MIT

Required Ruby Version: >= 0

Links: