RubyGems Navigation menu

wrappi 0.2.7

Wrappi is a Framework to create API clients. The intention is to bring the best practices and standardize how API clients behave. It allows to create API clients in a declarative way improving readability and unifying the behavior. It abstracts complex operations like caching, retries, background request and error handling. Enjoy!

Versions:

  1. 0.2.7 - September 15, 2019 (21 KB)
  2. 0.2.6 - August 25, 2019 (20.5 KB)
  3. 0.2.5 - June 12, 2019 (19.5 KB)
  4. 0.2.4 - June 04, 2019 (19.5 KB)
  5. 0.2.3 - April 08, 2019 (19.5 KB)
Show all versions (11 total)

Runtime Dependencies (4):

  • fusu ~> 0.2.1
  • http ~> 2.2
  • miller ~> 0.1.1
  • retryable >= 0
  • Development Dependencies (4):

  • bundler >= 0
  • rake ~> 10.0
  • rspec ~> 3.0
  • sinatra >= 0
  • Owners:

    Pushed by:

    Authors:

    • Artur Pañach

    SHA 256 checksum:

    60fc17ea31f415207cb5d9d026e3c01ca84c35e5c236908f1301f99fb392aa57

    Total downloads 14,380

    For this version 1,980

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    MIT

    Required Ruby Version: >= 0

    Links: