RubyGems Navigation menu

Magic 1.1.2

This extension provides access to the libmagic library, which is used (e.g. by the file(1) command) to identify the type of a binary or text file based on its initial bytes. The module offers a simple interface, with the bulk of the interface with libmagic being performed behind-the-scenes.

Versions:

  1. 1.1.2 - March 5, 2013 (19 KB)
  2. 1.1.1 - March 3, 2013 (19 KB)
  3. 1.1.0 - October 7, 2010 (19 KB)

Authors:

  • TG Community

Owners:

127b7dc3e95178445a2ba1b038623854

Total downloads 2,706

For this version 800

Required Ruby Version: None

Licenses:

GPLv3

Gemfile:
gem 'Magic', '~> 1.1.2' = Copy to clipboard Copied!

install:
gem install Magic = Copy to clipboard Copied!

Links: