RubyGems.org

SlimTest

4.6.1.1

ZenTest provides 4 different tools: zentest, unit_diff, autotest, and multiruby. ZenTest scans your target and unit-test code and writes your missing code based on simple naming rules, enabling XP at a much quicker pace. ZenTest only works with Ruby and Test::Unit. Nobody uses this tool anymore but it is the package namesake, so it stays. unit_diff is a command-line filter to diff expected results from actual results and allow you to quickly see exactly what is wrong. Do note that minitest 2.2+ provides an enhanced assert_equal obviating the need for unit_diff autotest is a continous testing facility meant to be used during development. As soon as you save a file, autotest will run the corresponding dependent tests. multiruby runs anything you want on multiple versions of ruby. Great for compatibility checking! Use multiruby_setup to manage your installed versions.

installgem install SlimTest
Authors

Ryan Davis, Eric Hodel

1,171 total downloads 1,164 for this version
Owners

428167a3ec72235ba971162924492609

Gemfile
gem 'SlimTest', '~> 4.6.1.1'
Versions
  1. 4.6.1.1 August 12, 2011 (63.5 KB)
Show all versions (2 total)
Development Dependencies
  1. hoe ~> 2.10