RubyGems Navigation menu

barcode1dtools 0.9.9.0

Barcode1D is a small library for handling many kinds of 1-dimensional barcodes. Currently implemented are Code 128, Code 3 of 9, Code 93, Code 11, Codabar, Interleaved 2 of 5, COOP 2 of 5, Matrix 2 of 5, Industrial 2 of 5, IATA 2 of 5, PostNet, Plessey, MSI (Modified Plessey), EAN-13, EAN-8, UPC-A, UPC-E, UPC Supplemental 2, and UPC Supplemental 5. Patterns are created in either a simple format of bars and spaces or as a run-length encoded string. This only generates and decodes the patterns; actual display or reading from a device must be implemented by the programmer.

Gemfile
          gem 'barcode1dtools', '~> 0.9.9.0'
  
  
  
  
  
  
  

install
          gem install barcode1dtools -v 0.9.9.0
  
  
  
  
  
  
  

Authors:

  • Michael Chaney

Owners:

Total downloads 17,764

For this version 1,182

Show all versions (16 total)

Required Ruby Version: None

Links:

Versions:

  1. 1.0.2.1 - October 3, 2012 (48 KB)
  2. 1.0.2.0 - October 3, 2012 (48.5 KB)
  3. 1.0.1.0 - September 27, 2012 (44 KB)
  4. 1.0.0.0 - September 27, 2012 (44 KB)
  5. 0.9.9.2 - September 22, 2012 (44 KB)
Show all versions (16 total)