RubyGems Navigation menu

barista 1.1.0.pre1

Barista provides simple, integrated support for CoffeeScript in Rack and Rails applications. Much like Compass does for Sass, It also provides Frameworks (bundleable code which can be shared via Gems). Lastly, it also provides a Rack Application (which can be used to server compiled code), a around_filter-style precompiler (as Rack middleware) and simple helpers for rails and Haml. For more details, please see the the README file bundled with it.

Gemfile
          gem 'barista', '~> 1.1.0.pre1'
  
  
  
  
  
  
  

install
          gem install barista --pre
  
  
  
  
  
  
  

Authors:

  • Darcy Laycock

Owners:

Total downloads 235,206

For this version 467

Show all versions (26 total)

Required Ruby Version: None

Links:

Versions:

  1. 1.3.0 - July 23, 2012 (22 KB)
  2. 1.2.1 - June 1, 2011 (20 KB)
  3. 1.2.0 - June 1, 2011 (20 KB)
  4. 1.1.0 - May 31, 2011 (20 KB)
  5. 1.1.0.pre1 - April 17, 2011 (19.5 KB)
Show all versions (26 total)

Runtime Dependencies: