RubyGems Navigation menu

buzzard 0.1.2

Love Sinatra, but feel it's just a little too minimalistic? Think Rails is way too bloated these days? Buzzard provides a set of modules for Sinatra and a minimalistic application generator. The modules provide a set of common, useful functionality for web application development without the overhead associated with heavier frameworks like Rails. Out of the box, your generated application will be configured with a set of modules providing functionality like data access via Ruby/DBI and session management. Further, placeholders are generated so you can see your application working right away. The best part is that you can pick and choose the bits of buzzard you want to use. Don't like Ruby/DBI? Use something else! Don't need sessions? You don't have to! Install the buzzard gem, then run "buzzard hello-world" to generate your first application.

Gemfile
          gem 'buzzard', '~> 0.1.2'
  
  
  
  
  
  
  

install
          gem install buzzard -v 0.1.2
  
  
  
  
  
  
  

Total downloads 6,950

For this version 1,718

Required Ruby Version: None

Links:

Versions:

  1. 0.1.4 - November 13, 2010 (9 KB)
  2. 0.1.3 - November 13, 2010 (9 KB)
  3. 0.1.2 - November 13, 2010 (9 KB)
  4. 0.1.1 - November 13, 2010 (8 KB)