RubyGems Navigation menu

cond 0.3.2

Cond allows errors to be handled near the place where they occur, before the stack unwinds. It offers several advantages over exceptions while peacefully coexisting with the standard exception behavior.

Gemfile
          gem 'cond', '~> 0.3.2'
  
  
  
  
  
  
  

install
          gem install cond
  
  
  
  
  
  
  

Authors:

  • James M. Lawrence

Owners:

Total downloads 7,811

For this version 1,421

Required Ruby Version: None

Links:

Versions:

  1. 0.3.2 - August 1, 2011 (23.5 KB)
  2. 0.3.1 - May 18, 2011 (23.5 KB)
  3. 0.3.0 - September 13, 2009 (24 KB)
  4. 0.2.1 - March 22, 2009 (20 KB)
  5. 0.2.0 - March 22, 2009 (20 KB)

Development Dependencies: