RubyGems Navigation menu

consoleappsupport 0.6.2

The ConsoleAppSupport module provides some commonly-desired behavior for command-line programs: currently command-line parsing; config file loading; and log4r integration. Its primary audience is Ruby coders who need to frequently and quickly write special-purpose scripts that are nevertheless flexible and self-documenting.

Versions:

  1. 0.6.2 - October 23, 2009 (11 KB)
  2. 0.6.1 - October 1, 2009 (11 KB)
  3. 0.5.1 - June 11, 2009 (10.5 KB)
  4. 0.5.0 - June 8, 2009 (10.5 KB)

Runtime Dependencies:

Development Dependencies:

Authors:

  • benton

Owners:

A2654ed4bc14d241da560221f7f4f646992bfa5b09df66f35282e996ebfa4fd4

Total downloads 7,303

For this version 2,150

Required Ruby Version: None

Licenses:

N/A

Gemfile:
gem 'consoleappsupport', '~> 0.6.2' = Copy to clipboard Copied!

install:
gem install consoleappsupport = Copy to clipboard Copied!

Links: