RubyGems Navigation menu

date_scopes 0.1.2

Adds a simple macro, has_date_scopes to ActiveRecord. When used it adds a number of convinience scopes to your models relating to a whether a particular date field on that model is in the past or future. It also has other handy features.

Gemfile
          gem 'date_scopes', '~> 0.1.2'
  
  
  
  
  
  
  

install
          gem install date_scopes -v 0.1.2
  
  
  
  
  
  
  

Authors:

  • Jonathan Davies, ThroughTheNet

Owners:

Total downloads 9,417

For this version 1,557

Show all versions (6 total)

Required Ruby Version: None

Links:

Versions:

  1. 0.1.5 - February 1, 2011 (12 KB)
  2. 0.1.4 - January 28, 2011 (11.5 KB)
  3. 0.1.3 - January 27, 2011 (9 KB)
  4. 0.1.2 - December 2, 2010 (11.5 KB)
  5. 0.1.1 - December 2, 2010 (11.5 KB)
Show all versions (6 total)

Runtime Dependencies: