RubyGems Navigation menu

deprecatable 1.0.0

Deprecatable is a library to help you, as a developer, deprecate your API and be proactive about helping people who use your library find where they need to update. When using Deprecatable, you mark methods as 'deperecated' and then the users of your API will receive a helpful alert showing the exact line of code where they called the deprecated API, and what they need to do to fix it (although you need to supply this piece of information). Users will receive, by default, a single alert for each unique location a deprecated API method is invoked. They will also receive a final report detailing all the locations where deprecated APIs were invoked. The "noisiness" of the alerting and the final report is all configurable, via both code, and environment variables. See Deprecatable::Options.

Versions:

  1. 1.0.0 - August 9, 2011 (18 KB)

Authors:

  • Jeremy Hinegardner

Owners:

Cff2d90ae70bbbb5d4865d8412159f85

Total downloads 1,457

For this version 1,457

Required Ruby Version: None

Licenses:

N/A

Gemfile:
gem 'deprecatable', '~> 1.0.0' = Copy to clipboard Copied!

install:
gem install deprecatable = Copy to clipboard Copied!

Links: