RubyGems Navigation menu

dirty-memoize 0.0.4

Like Memoize, but designed for mutable and parametizable objects Use when: 1. You have one expensive method (\compute) which set many internal variables. So, is preferable lazy evaluation of these dependent variables. 2. The expensive operation depends on one or more parameters 3. Changes on one or more parameters affect all dependent variables 4. You may want to hide the call of 'compute' operation 5. The user could want test several different parameters values

Gemfile
          gem 'dirty-memoize', '~> 0.0.4'
  
  
  
  
  
  
  

install
          gem install dirty-memoize
  
  
  
  
  
  
  

Authors:

  • Claudio Bustos

Owners:

Total downloads 90,564

For this version 86,267

Required Ruby Version: None

Links:

Versions:

  1. 0.0.4 - January 26, 2011 (10 KB)
  2. 0.0.3 - April 1, 2010 (7 KB)
  3. 0.0.1 - April 1, 2010 (7 KB)

Development Dependencies: