RubyGems.org

enumerate_it

1.2.0

Have a legacy database and need some enumerations in your models to match those stupid '4 rows/2 columns' tables with foreign keys and stop doing joins just to fetch a simple description? Or maybe use some integers instead of strings as the code for each value of your enumerations? Here's EnumerateIt.

installgem install enumerate_it -v 1.2.0
Authors

Cássio Marques

103,374 total downloads 14,109 for this version
Owners

E9202d96b693676af44a254915e1a48f

Gemfile
gem 'enumerate_it', '~> 1.2.0'
Versions
  1. 1.2.3 July 25, 2014 (16.5 KB)
  2. 1.2.2 July 10, 2014 (17 KB)
  3. 1.2.1 March 7, 2014 (17 KB)
  4. 1.2.0 August 16, 2013 (16.5 KB)
  5. 1.1.1 July 3, 2013 (16 KB)
Show all versions (34 total)
Runtime Dependencies
  1. activesupport >= 3.0.0