RubyGems Navigation menu

flex_coerce 0.0.1

FlexCoerce - is a gem which allow you create operator-dependent coercion logic. It's useful when your type should be treated in a different way for different binary operations (including arithmetic operators, bitwise operators and comparison operators except equality checks: `==`, `===`).

Gemfile
          gem 'flex_coerce', '~> 0.0.1'
  
  
  
  
  
  
  

install
          gem install flex_coerce
  
  
  
  
  
  
  

Licenses:

  • MIT

Total downloads 755

For this version 755

Required Ruby Version: None

Links:

Versions:

  1. 0.0.1 - March 8, 2013 (8 KB)