RubyGems Navigation menu

micro-optparse 1.2.0

This is an lightweight option parser, which is less than 80 lines short. It has strong validations and a short, clear and easy to use syntax. Feel free to copy all 80 lines (55 lines without validations / empty lines) into your script rather installing the gem.

Versions:

  1. 1.2.0 - December 29, 2013 (13 KB)
  2. 1.1.5 - June 19, 2011 (9.5 KB)
  3. 1.1.4 - June 12, 2011 (9.5 KB)
  4. 1.1.3 - April 18, 2011 (9.5 KB)
  5. 1.0.2 - March 18, 2011 (9 KB)
Show all versions (10 total)

Development Dependencies:

Authors:

  • Florian Pilz

Owners:

99ad49aa1ba791f0d537a1b5620dd2eb

Total downloads 15,005

For this version 2,077

Show all versions (10 total)

Required Ruby Version: None

Licenses:

MIT

Gemfile:
gem 'micro-optparse', '~> 1.2.0' = Copy to clipboard Copied!

install:
gem install micro-optparse = Copy to clipboard Copied!

Links: