RubyGems.org

most

0.7.7

Most is a simple academic modular open software tester. Most, the Core is the main part of the system. Most provides the environment and interface bridges for modules that will implement the basic functionality of the testing system. In general Most, the Core consists form two main interfaces: the connector and the tester. The connector interface offers the basic bridge to make an implementation of a module which will act as a controlling interface of the system. It can be a command line interface or it can be a module which will set up a server providing a network access for end users. The tester interface allows building an implementation of the software validator. By default the Most ships with the tester compliant with the ICPC Validator Standard. The Most system proposes to implement a testing system following this standard, but it is not obligatory. The 3-rd party implementation can vary significantly considering the user preferences. It is possible to build other interface bridges using the abstract interface classes provided by the Most system to extend the functionality of the modules. For example the implementation of the connector interface in the form of the network server can build a tunnel interface bridge, so that developers can make implementations, for example, of a SSH tunnel in order to provide a secure connection with the testing system. The default system bundle is shipped with a number of basic interface implementations (modules). Please, consider taking a look on realize notes for the list of supplied modules.

installgem install most
Authors

Toksaitov Dmitrii Alexandrovich

17,721 total downloads 12,252 for this version
Owners

F4a11926f046dbe248906afa5b67cbcc

Gemfile
gem 'most', '~> 0.7.7'
Versions
  1. 0.7.7 October 13, 2009 (51.5 KB)
  2. 0.7.6 October 29, 2009 (52 KB)
  3. 0.7.5 October 27, 2009 (35.5 KB)
  4. 0.7.4 October 27, 2009 (35.5 KB)
  5. 0.7.3 October 27, 2009 (35.5 KB)
Runtime Dependencies
  1. sys-proctable >= 0.9.0
Development Dependencies
  1. hoe >= 2.3.3
  2. newgem >= 1.5.1