RubyGems.org

pg

0.17.0

Pg is the Ruby interface to the {PostgreSQL RDBMS}[http://www.postgresql.org/]. It works with {PostgreSQL 8.4 and later}[http://www.postgresql.org/support/versioning/]. A small example usage: #!/usr/bin/env ruby require 'pg' # Output a table of current connections to the DB conn = PG.connect( dbname: 'sales' ) conn.exec( "SELECT * FROM pg_stat_activity" ) do |result| puts " PID | User | Query" result.each do |row| puts " %7d | %-16s | %s " % row.values_at('procpid', 'usename', 'current_query') end end

installgem install pg -v 0.17.0
Authors

Michael Granger, Lars Kanis

10,886,954 total downloads 786,064 for this version
Owners

Feef2024584d97a97338b964661ca795Abc11c007a3a284272d261b2dae6376e04cdb622ce0aac272b61f23f373e2abf

Licenses

BSD, Ruby, GPL

Gemfile
gem 'pg', '~> 0.17.0'
Versions
  1. 0.18.0.pre20140820094244 August 20, 2014 (141 KB)
  2. 0.17.2.pre.546 July 25, 2014 (140 KB)
  3. 0.17.1 December 19, 2013 (140 KB)
  4. 0.17.1 December 19, 2013 x86-mingw32 (3.87 MB)
  5. 0.17.1 December 19, 2013 x64-mingw32 (2.31 MB)
Show all versions (74 total)