RubyGems Navigation menu

pg_jruby 0.14.1.rc1-java

This is a native implementation of the Postsgres protocol written entirely in Java. The project was started by @headius as a ruby-pg replacement for JRuby that uses the JDBC driver and private API of Postgres. Unfortunately ruby-pg (which uses libpq under the hood) exposed a lot of features of Postgres that were impossible to implement or were complicated given the nature of the JDBC and the encapsulation of many features that are exposed in ruby-pg. *WARNING* this gem is not production ready yet. There are many bugs that needs to be fixed and more testing. So please checkout the code and submit pull requests with some fixes. If your Java-Fu isn't that great you can still contribute by submitting test cases and We'll be happy to fix them.

Gemfile
          gem 'pg_jruby', '~> 0.14.1.rc1'
  
  
  
  
  
  
  

install
          gem install pg_jruby -v 0.14.1.rc1 --pre
  
  
  
  
  
  
  

Total downloads 39,713

For this version 566

Required Ruby Version: None

Links: