RubyGems.org

rack-goggles

1.1.0

See a "pretty" version of your API. Goggles installs a little tiny Sinatra app on a URL prefix and serves any JSON responses that come back as a prettyprinted HTML page. There are browser add-ons that do a great job with this sort of thing, but I wanted something I could live-link from API docs. This could be a lot fancier and prettier, I just extracted the bare minimum from a production app. Patches welcome.

installgem install rack-goggles
Authors

John Barnette

2,321 total downloads 1,200 for this version
Owners

A21b8d121dbf1ff5ff5eddd734949217

Gemfile
gem 'rack-goggles', '~> 1.1.0'
Versions
  1. 1.1.0 September 18, 2010 (56.5 KB)
  2. 1.0.0 September 17, 2010 (56.5 KB)
Runtime Dependencies
  1. sinatra >= 1.0
Development Dependencies
  1. hoe >= 2.6.2