RubyGems.org

Ruby 1.9's require_relative for Rubinius and MRI 1.8. We also add abs_path which is like __FILE__ but __FILE__ can be fooled by a sneaky "chdir" while abs_path can't. If you are running on Ruby 1.9 or greater, require_relative is the pre-defined version. The benefit we provide in this situation by this package is the ability to write the same require_relative sequence in Rubinius 1.8 and Ruby 1.9.

installgem install rbx-require-relative -v 0.0.7
Authors

R. Bernstein

915,166 total downloads 944 for this version
Owners

00341644ed62ea57e07b217e6009cf22

Gemfile
gem 'rbx-require-relative', '~> 0.0.7'
Versions
  1. 0.0.9 February 27, 2012 (8.5 KB)
  2. 0.0.7 February 26, 2012 (8.5 KB)
  3. 0.0.7 February 26, 2012 universal-rubinius-1.2 (8.5 KB)
  4. 0.0.7 February 26, 2012 universal-ruby-1.9.3 (8.5 KB)
  5. 0.0.7 February 26, 2012 universal-ruby-1.8.7 (8.5 KB)
Show all versions (19 total)