RubyGems Navigation menu

roodi 2.0.1

Roodi stands for Ruby Object Oriented Design Inferometer. It parses your Ruby code and warns you about design issues you have based on the checks that is has configured.

Gemfile
          gem 'roodi', '~> 2.0.1'
  
  
  
  
  
  
  

install
          gem install roodi -v 2.0.1
  
  
  
  
  
  
  

Total downloads 391,897

For this version 6,142

Show all versions (25 total)

Required Ruby Version: None

Links:

Versions:

  1. 4.0.0 - April 10, 2014 (22 KB)
  2. 3.3.1 - November 9, 2013 (22 KB)
  3. 3.3.0 - November 9, 2013 (22 KB)
  4. 3.2.0 - November 9, 2013 (22 KB)
  5. 3.1.1 - August 25, 2013 (21.5 KB)
Show all versions (25 total)

Runtime Dependencies:

Development Dependencies: