RubyGems Navigation menu

ruboss4ruby 1.1.2

The Ruboss Framework brings the design principles and productivity of Rails to Flex development, and makes integration with RESTful APIs as simple as possible. Here's some of the things you can do: * *Create* a complete _Adobe_ _Flex_ or _AIR_ application in less than 5 minutes. Use our lightweight Ruby-based code generation toolkit to create a fully functional CRUD application. Simply do: sudo gem install ruboss4ruby And then run: ruboss-gen -h * *Integrate* with _Ruby_ _On_ _Rails_, _Merb_ or _Sinatra_ applications that use _ActiveRecord_, _DataMapper_, _CouchRest_, _ActiveCouch_, etc. * *Communicate* between your Flex/AIR rich client and service providers using either _XML_ or _JSON_. * *Persist* your data directly in Adobe AIR's _SQLite_ database or _CouchDB_ without any additional infrastructure or intermediate servers. * *Deploy* your Ruboss application on the Google App Engine and use Google DataStore for persistence.

Versions:

  1. 1.1.2 - January 11, 2009 (117 KB)
  2. 1.1.1 - January 9, 2009 (114 KB)
  3. 1.1.0 - January 9, 2009 (114 KB)
  4. 1.0.5 - October 21, 2008 (111 KB)
  5. 1.0.4 - October 21, 2008 (111 KB)
Show all versions (8 total)

Development Dependencies:

Authors:

  • Dima Berastau

Owners:

4d0cafc12f4241d5ac68407faa9c24b6

Total downloads 10,551

For this version 1,459

Show all versions (8 total)

Required Ruby Version: None

Licenses:

N/A

Gemfile:
gem 'ruboss4ruby', '~> 1.1.2' = Copy to clipboard Copied!

install:
gem install ruboss4ruby = Copy to clipboard Copied!

Links: