RubyGems Navigation menu

safe_ruby 1.0.1

Evaluates ruby code by writing it to a tempfile and spawning a child process. Uses a whitelist of methods and constants to keep, for example one cannot run system commands in the environment created by this gem. The environment created by the untrusted code does not leak out into the parent process.

Versions:

  1. 1.0.1 - December 4, 2013 (7 KB)
  2. 1.0.0 - December 4, 2013 (7 KB)
  3. 0.0.1 - December 4, 2013 (7 KB)

Runtime Dependencies:

Development Dependencies:

Authors:

  • Uku Taht

Owners:

051d7d3cccb9ec47de909157ce759f42

Total downloads 1,223

For this version 436

Required Ruby Version: None

Licenses:

MIT

Gemfile:
gem 'safe_ruby', '~> 1.0.1' = Copy to clipboard Copied!

install:
gem install safe_ruby = Copy to clipboard Copied!

Links: