RubyGems.org

smtp_tls

1.0.2

Provides SMTP STARTTLS support for Ruby 1.8.6 (built-in for 1.8.7+). Simply require 'smtp_tls' and use the Net::SMTP#enable_starttls method to talk to servers that use STARTTLS. require 'net/smtp' begin require 'smtp_tls' rescue LoadError end smtp = Net::SMTP.new address, port smtp.enable_starttls smtp.start Socket.gethostname, user, password, authentication do |server| server.send_message message, from, to end

installgem install smtp_tls -v 1.0.2
Authors

Eric Hodel, Kyle Maxwell

13,584 total downloads 1,264 for this version
Owners

58479f76374a3ba3c69b9804163f39f4

Gemfile
gem 'smtp_tls', '~> 1.0.2'
Versions
  1. 1.0.3 July 8, 2009 (10 KB)
  2. 1.0.2 June 25, 2009 (8.5 KB)
  3. 1.0.1 June 24, 2009 (8.5 KB)
  4. 1.0 June 24, 2009 (8.5 KB)
Runtime Dependencies
  1. hoe >= 2.3.0
Development Dependencies
  1. hoe >= 2.3.0