RubyGems Navigation menu

sword2ruby 1.0.1

The Sword2Ruby gem provides Sword client functionality when run against a Sword 2.0 compliant server. It eases integration of Ruby applications with Sword servers, taking care of things like authentication, deposit-receipts and the parsing of Sword tags. It was developed as part of the JISC Sword 2.0 project. For more information on Sword, see: http://www.swordapp.org/. The Sword 2 specification can be found at: http://swordapp.org/sword-v2/sword-v2-specifications/ This code lives at https://github.com/swordapp/sword2ruby.

Versions:

  1. 1.0.1 - October 10, 2013 (151 KB)
  2. 1.0.0 - April 15, 2012 (150 KB)

Development Dependencies:

Authors:

  • Mark MacGillivray, Martyn Whitwell

Owners:

3ec47d93ef4b6f53f9032f6f10f8b5a1

Total downloads 1,538

For this version 500

Required Ruby Version: None

Licenses:

N/A

Gemfile:
gem 'sword2ruby', '~> 1.0.1' = Copy to clipboard Copied!

install:
gem install sword2ruby = Copy to clipboard Copied!

Links: