RubyGems.org

Set transaction isolation level in the ActiveRecord in a database agnostic way. Works with MySQL, PostgreSQL and SQLite as long as you are using new adapters mysql2, pg or sqlite3. Supports all ANSI SQL isolation levels: :serializable, :repeatable_read, :read_committed, :read_uncommitted.

installgem install transaction_isolation
Authors

Piotr 'Qertoip' WĹ‚odarek

45,785 total downloads 44,068 for this version
Owners

B8cd05c1c25969a0b3044bfc9f2da6d7

Gemfile
gem 'transaction_isolation', '~> 1.0.3'
Versions
  1. 1.0.3 February 8, 2012 (10.5 KB)
  2. 1.0.2 February 6, 2012 (10.5 KB)
  3. 1.0.1 February 6, 2012 (10 KB)
Runtime Dependencies
  1. activerecord >= 3.0.11