RubyGems Navigation menu

wiringpi2 2.0.1

WiringPi library wrapper for the Raspberry Pi only. Wraps up version 2.x of the Arduino wiring-like WiringPi library into a convinient Ruby gem. Currently includes GPIO functionality, I2C, SPI, serial and shiftOut/shiftIn support in addition to peripheral drivers for things like the MCP23017. Credit to Gordon for the WiringPi library, which can be found here: http://www.wiringpi.com

Gemfile
          gem 'wiringpi2', '~> 2.0.1'
  
  
  
  
  
  
  

install
          gem install wiringpi2
  
  
  
  
  
  
  

Licenses:

  • GNU Lesser General Public License v3

Total downloads 1,125

For this version 650

Required Ruby Version: None

Links:

Versions:

  1. 2.0.1 - April 7, 2013 (72.5 KB)
  2. 2.0.0 - April 7, 2013 (72.5 KB)