RubyGems Navigation menu

words 0.4.6

Words, with both pure ruby & tokyo-cabinate backends, implements a fast interface to Wordnet over the same easy-to-use API. The FFI backend makes use of Tokyo Cabinet and the FFI interface, rufus-tokyo, to provide cross ruby distribution compatability and blistering speed. The pure ruby interface operates on a special ruby optimised index along with the basic dictionary files provided by WordNet. I have attempted to provide ease of use in the form of a simple yet powerful api and installation is a sintch!

Gemfile
          gem 'words', '~> 0.4.6'
  
  
  
  
  
  
  

install
          gem install words
  
  
  
  
  
  
  

Authors:

  • Roja Buck

Owners:

Total downloads 15,895

For this version 1,233

Show all versions (13 total)

Required Ruby Version: None

Links:

Versions:

  1. 0.4.6 - September 21, 2012 (29 KB)
  2. 0.4.5 - September 21, 2012 (29 KB)
  3. 0.4.4 - June 19, 2010 (29 KB)
  4. 0.4.3 - June 19, 2010 (29 KB)
  5. 0.4.2 - June 19, 2010 (29 KB)
Show all versions (13 total)

Development Dependencies: