RubyGems Navigation menu

yoomee-decent_exposure 1.2.1

DecentExposure helps you program to an interface, rather than an implementation in your Rails controllers. The fact of the matter is that sharing state via instance variables in controllers promotes close coupling with views. DecentExposure gives you a declarative manner of exposing an interface to the state that controllers contain and thereby decreasing coupling and improving your testability and overall design.

Versions:

  1. 1.2.1 - November 24, 2011 (7 KB)
  2. 1.2.0 - November 24, 2011 (7 KB)
  3. 1.0.2 - November 24, 2011 (7 KB)
  4. 1.0.1 - November 14, 2011 (7.5 KB)

Authors:

  • Stephen Caudill, Jon Larkowski

Owners:

E38104ce0fd4bce41475a6a35e64c47c

Total downloads 4,586

For this version 1,426

Required Ruby Version: None

Licenses:

N/A

Gemfile:
gem 'yoomee-decent_exposure', '~> 1.2.1' = Copy to clipboard Copied!

install:
gem install yoomee-decent_exposure = Copy to clipboard Copied!

Links: