RubyGems Navigation menu

autobuild 1.5.38

This work is licensed under the GPLv2 license. See License.txt for details

What's autobuild ?

Autobuild imports, configures, builds and installs various kinds of software packages. It can be used in software development to make sure that nothing is broken in the build process of a set of packages, or can be used as an automated installation tool.

Autobuild config files are Ruby scripts which configure rake to

  • imports the package from a SCM or (optionnaly) updates it

  • configures it. This phase can handle code generation, configuration (for instance for autotools-based packages), …

  • build

  • install

It takes the dependencies between packages into account in its build process, updates the needed environment variables (PKG_CONFIG_PATH, PATH, LD_LIBRARY_PATH, …)

版本列表:

  1. 1.18.1 - May 10, 2019 (91.5 KB)
  2. 1.18.0 - March 27, 2019 (91.5 KB)
  3. 1.17.0 - February 18, 2019 (89.0 KB)
  4. 1.16.0 - November 22, 2018 (88.5 KB)
  5. 1.15.0 - August 31, 2018 (88.0 KB)
  6. 1.5.38 - May 13, 2011 (70.0 KB)
显示所有 (247 个版本)

Development 依赖关系 (1):

作者:

  • Sylvain Joyeux

所有者:

SHA 256 checksum:

b91e339e20615b3a6f609cad0bcefa59a97c3b57f0487f6f9f3b31573eef7b00

下载总次数 522,902

这个版本 3,041

Gemfile:
= 复制到剪贴板 已复制

安装:
=

许可s:

需要的 Ruby 版本:

相关链接: