RubyGems Navigation menu

barista 1.3.0

Barista provides simple, integrated support for CoffeeScript in Rack and Rails applications. Much like Compass does for Sass, It also provides Frameworks (bundleable code which can be shared via Gems). Lastly, it also provides a Rack Application (which can be used to server compiled code), a around_filter-style precompiler (as Rack middleware) and simple helpers for rails and Haml. For more details, please see the the README file bundled with it.

Gemfile:
= Copy to clipboard Copied!

install:
=

Versions:

  1. 1.3.0 - July 23, 2012 (22 KB)
  2. 1.2.1 - June 02, 2011 (20 KB)
  3. 1.2.0 - June 02, 2011 (20 KB)
  4. 1.1.0 - June 01, 2011 (20 KB)
  5. 1.1.0.pre1 - April 18, 2011 (19.5 KB)
Show all versions (26 total)

Runtime Dependencies (1):

coffee-script ~> 2.2

Development Dependencies (9):

jeweler ~> 1.0
rails ~> 3.0
rdoc ~> 2.4
rr ~> 1.0
rspec ~> 2.6
rspec-core ~> 2.6
rspec-rails ~> 2.6
ruby-debug >= 0
ruby-debug19 ~> 0.11

Owners:

Authors:

  • Darcy Laycock

SHA 256 checksum:

= Copy to clipboard Copied!

Total downloads 430,404

For this version 145,529

Licenses:

N/A

Required Ruby Version: None

Links: