RubyGems Navigation menu

ffi-rzmq 0.7.2

This gem wraps the ZeroMQ networking library using the ruby FFI (foreign function interface). It's a pure ruby wrapper so this gem can be loaded and run by any ruby runtime that supports FFI. That's all of them: MRI 1.9.x, Rubinius and JRuby. The impetus behind this library was to provide support for ZeroMQ in JRuby which has native threads. Unlike MRI, IronRuby and Rubinius which all have a GIL, JRuby allows for threaded access to ruby code from outside extensions. ZeroMQ is heavily threaded, so until the other runtimes remove their GIL, JRuby will likely be the best environment to run this library.

Versions:

  1. 2.0.7 - January 05, 2019 (50 ko)
  2. 2.0.6 - February 22, 2018 (47 ko)
  3. 2.0.5 - March 24, 2017 (46,5 ko)
  4. 2.0.4 - January 28, 2015 (46 ko)
  5. 2.0.1 - January 22, 2014 (45 ko)
  6. 0.7.2 - February 24, 2011 (31,5 ko)
Voir toutes les versions (23)

Dépendances de Development (1):

  • bones >= 3.5.4
  • Propriétaires:

    Auteurs:

    • Chuck Remes

    Total de contrôle SHA 256:

    a7a4d7dde651746b8f86dae4f41d33790ef05a545b970b53f57fcf1c5f2f7d41

    Total de téléchargements 741 422

    Pour cette version 4 082

    Gemfile:
    = Copier Copié!

    installation:
    =

    Licences:

    aucune

    Version de Ruby requise: None

    Liens: