RubyGems Navigation menu

flex_coerce 0.0.1

FlexCoerce - is a gem which allow you create operator-dependent coercion logic. It's useful when your type should be treated in a different way for different binary operations (including arithmetic operators, bitwise operators and comparison operators except equality checks: `==`, `===`).

Versions:

  1. 0.0.1 - March 08, 2013 (8 KB)

Development Dependencies (4):

  • bundler ~> 1.3
  • rake >= 0
  • rspec >= 2.0
  • rspec-given >= 2.0.0
  • Owners:

    Authors:

    • Ilya Vorontsov

    SHA 256 checksum:

    e9aabeb4739705f428a502cf7dc5c34822e08e3a7979a3c7a871ddebf4038898

    Total downloads 2,859

    For this version 2,859

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    MIT

    Required Ruby Version: = 2.0.0

    Links: