RubyGems Navigation menu

github_api 0.15.0

Ruby client that supports all of the GitHub API methods. It's build in a modular way, that is, you can either instantiate the whole api wrapper Github.new or use parts of it e.i. Github::Client::Repos.new if working solely with repositories is your main concern. Intuitive query methods allow you easily call API endpoints.

Versions:

  1. 0.18.1 - October 07, 2017 (141 KB)
  2. 0.17.0 - April 18, 2017 (140 KB)
  3. 0.16.0 - April 02, 2017 (139 KB)
  4. 0.15.0 - March 25, 2017 (137 KB)
  5. 0.14.5 - August 07, 2016 (136 KB)
Show all versions (89 total)

Development Dependencies (2):

Authors:

  • Piotr Murach

Owners:

Fb249d5564a0f8c5a0b69e0d71d58949

SHA 256 checksum:

fb4c7577bf73e350c4383cad97c4f954692b724b362a4af300219a24824567bf

Total downloads 1,530,367

For this version 5,949

Gemfile:
= Copy to clipboard Copied!

install:
=

License:

MIT

Required Ruby Version: >= 1.9.2

Links: