RubyGems Navigation menu

github_api 0.4.11

Ruby wrapper that supports all of the GitHub API v3 methods(nearly 200). It's build in a modular way, that is, you can either instantiate the whole api wrapper Github.new or use parts of it e.i. Github::Repos.new if working solely with repositories is your main concern.

Versions:

  1. 0.19.0 - June 22, 2020 (148 KB)
  2. 0.18.2 - November 19, 2017 (141 KB)
  3. 0.18.1 - October 07, 2017 (141 KB)
  4. 0.17.0 - April 18, 2017 (140 KB)
  5. 0.16.0 - April 02, 2017 (139 KB)
  6. 0.4.11 - April 22, 2012 (157 KB)
Show all versions (91 total)

Runtime Dependencies (5):

  • faraday ~> 0.7.6
  • hashie ~> 1.2.0
  • multi_json ~> 1.3
  • nokogiri ~> 1.5.2
  • oauth2 ~> 0.5.2
  • Development Dependencies (11):

  • bundler >= 0
  • cucumber >= 0
  • guard ~> 0.8.8
  • guard-cucumber = 0.7.4
  • guard-rspec = 0.5.7
  • rake >= 0
  • rspec >= 0
  • simplecov ~> 0.6.1
  • vcr ~> 2.0.0
  • webmock ~> 1.8.0
  • yajl-ruby ~> 1.1.0
  • Owners:

    Authors:

    • Piotr Murach

    SHA 256 checksum:

    cf2abfcc3700522b89d954c9d92f751503766c46f51d97b165962977f8466fe7

    Total downloads 3,087,685

    For this version 3,378

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    Licenses:

    N/A

    Required Ruby Version: None

    Links: