RubyGems Navigation menu

glimmer-dsl-libui 0.4.10

Glimmer DSL for LibUI (Prerequisite-Free Ruby Desktop Development GUI Library) - No need to pre-install any prerequisites. Just install the gem and have platform-independent native GUI that just works! Glimmer DSL for LibUI aims to provide declarative DSL syntax that visually maps to GUI control hierarchy, convention over configuration via smart defaults, automation of low-level details, requiring the least amount of syntax possible to build GUI, and custom keyword support.

Versions:

  1. 0.4.10 - December 01, 2021 (152 KB)
  2. 0.4.9 - November 30, 2021 (151 KB)
  3. 0.4.8 - November 29, 2021 (150 KB)
  4. 0.4.7 - November 29, 2021 (150 KB)
  5. 0.4.6 - November 29, 2021 (148 KB)
Show all versions (82 total)

Runtime Dependencies (5):

  • chunky_png ~> 1.4.0
  • color ~> 1.8
  • glimmer ~> 2.5.0
  • libui ~> 0.0.13
  • os >= 1.0.0, < 2.0.0
  • Development Dependencies (7):

  • coveralls = 0.8.23
  • juwelier >= 2.4.9, < 3.0.0
  • puts_debuggerer ~> 0.13.1
  • rake-tui >= 0.2.1
  • rspec ~> 3.0
  • simplecov ~> 0.16.1
  • simplecov-lcov ~> 0.7.0
  • Owners:

    Pushed by:

    Authors:

    • Andy Maleh

    SHA 256 checksum:

    42cce4fa4c402c7445fb7d95f1afb5b2d892a46e9a709fe7c44027795acc0869

    Total downloads 18,038

    For this version 43

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    MIT

    Required Ruby Version: >= 0

    Links: