RubyGems Navigation menu

http-cookie 1.0.6

HTTP::Cookie is a Ruby library to handle HTTP Cookies based on RFC 6265. It has with security, standards compliance and compatibility in mind, to behave just the same as today's major web browsers. It has builtin support for the legacy cookies.txt and the latest cookies.sqlite formats of Mozilla Firefox, and its modular API makes it easy to add support for a new backend store.

Gemfile:
= Copy to clipboard Copied!

install:
=

Versions:

  1. 1.0.6 - June 01, 2024 (39.5 KB)
  2. 1.0.5 - May 25, 2022 (38.5 KB)
  3. 1.0.4 - June 07, 2021 (38.5 KB)
  4. 1.0.3 - September 30, 2016 (37.5 KB)
  5. 1.0.2 - September 10, 2013 (37 KB)
Show all versions (25 total)

Runtime Dependencies (1):

domain_name ~> 0.5

Development Dependencies (6):

bundler >= 1.2.0
rake >= 0.9.2.2
rdoc > 2.4.2
simplecov >= 0
sqlite3 ~> 1.3
test-unit >= 2.4.3

Owners:

Pushed by:

Authors:

  • Akinori MUSHA, Aaron Patterson, Eric Hodel, Mike Dalessio

SHA 256 checksum:

= Copy to clipboard Copied!

Total downloads 441,057,917

For this version 4,632,894

License:

MIT

Required Ruby Version: >= 0

Links: