RubyGems Navigation menu

metasploit_data_models 1.3.0

Implements minimal ActiveRecord models and database helper code used in both the Metasploit Framework (MSF) and Metasploit commercial editions.

Versions:

  1. 5.0.0 - April 29, 2021 (175 KB)
  2. 4.1.4 - April 29, 2021 (175 KB)
  3. 4.1.3 - April 08, 2021 (175 KB)
  4. 4.1.2 - February 18, 2021 (175 KB)
  5. 4.1.1 - November 30, 2020 (175 KB)
  6. 1.3.0 - March 07, 2016 (173 KB)
Show all versions (180 total)

Runtime Dependencies (9):

  • activerecord < 4.1.0, >= 4.0.9
  • activesupport < 4.1.0, >= 4.0.9
  • arel-helpers >= 0
  • metasploit-concern ~> 1.1
  • metasploit-model ~> 1.1
  • pg >= 0
  • postgres_ext >= 0
  • railties < 4.1.0, >= 4.0.9
  • recog ~> 2.0
  • Development Dependencies (7):

    Owners:

    Authors:

    • Samuel Huckins, Luke Imhoff, David 'thelightcosine' Maloney, Trevor 'burlyscudd' Rosen

    SHA 256 checksum:

    fb3194d039516b5056a33e60d46781726544b785d926b25ad040595c4c3e7c39

    Total downloads 2,209,156

    For this version 19,955

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    Licenses:

    N/A

    Required Ruby Version: >= 2.1

    Links: